Hover grapth (thumbnail) window width 600 px


I have a problem with a size of thimbnail preview. It has wixed wide 600 and ignores any settings I put in configuration (default is 250 but I have changed it to 150 - I cannot add second screenshot as a new user here).
How can I effectivly narrow preview window width? Present size is much too big.

Here is a screenshot of general settings.


Try this if you still stuck there.

OS: ubuntu 22.04
file name:weathermap.js
file location:/cacti/plugins/weathermap/js/
to fix your problem, you can do this:

  1. open weathermap.js with text editor
  2. find “ui.tooltip.css(‘min-width’, ‘60px’);” , probably at line 16.
    and the original data should be “ui.tooltip.css(‘min-width’, ‘600px’);” (maybe it’s not 600, I forgot)
  3. change 600 to any number you need.
  4. change the weathermap setting on cacti (Hover Graph Default Width:), set to what you need, (400 is a suitable value)
  5. be sure that the value of min-width in weathermap.js is less than the value of “Hover Graph Default Width” in cacti.
  6. after above things done, check your hover graph, if nothing changed, waiting some time or clearing your cache and then reload the page.