Observium does not open weathermap

#1

Good morning I’m trying to open in the observium but without success!
I already did the installation as
this link (https://github.com/akender/weathermap-for-observium) but I have no success opening the map in the Observium web interface !!
Is there anything I can check to find possible errors?

#2

You might get better answers from either Observium or akender.

Also, what does “no success” mean? The computer catches fire? There’s an error message? A blank page? No link in the UI?

#3

Actually nothing appears is loading a page and then appears that could not load !!

#4

Then have a look at the webserver error log. PHP errors (which that most likely is) will show up there.

#5

[Mon Aug 12 14:10:03.271464 2019] [php7:emerg] [pid 4161] [client 138…:54549] PHP Parse error: syntax error, unexpected ‘.’, expecting end of file in /opt/observium/html/weathermap/editor-config.php on line 11,

#6
<?php $config_weathermap_groups = array( "gr1"=>"Group1", "gr2"=>"Group2"); $config_weathermap_observiumbase = 'http://..../'; $config_weathermap_mapdir = 'configs'; $config_weathermap_version = '0.97c'; .?>
#7

It’s true, that . right at the end is unexpected :slight_smile:

#8

I’m almost giving up tried to install !!
Tried on cacti 1x did not give! Tried on zabbix could not! I tried in the observium did not give I do not know which install to use the map I’m already a few months trying and nothing !!

#9

Did you try to remove the dot that it is complaining about above?

I can’t really help with “cannot” though. There is no information to work with.

#10

Thanks for the attention I removed the point and the map has now opened and just mounting the map excuses the inconvenience !!