Php: fatal error after moving weathermap

#1

I’ve moved weathermap to new instalation of observium, and i can’t run the map-poller, i get this error:

/opt/observium/html/weathermap/map-poller.php
PHP Fatal error: require_once(): Failed opening required ‘random_compat/random.php’ (include_path=’/libs/pear:/libs:.:/usr/share/pear:/usr/share/php’) in /opt/observium/includes/definitions.inc.php on line 160

maybe you can how i can cope with this ?

Thanks

#2

That looks like it’s a file inside observium that’s trying to include another file inside observium that doesn’t exist. The plugin for observium (I actually didn’t know there was one!) is also from someone else… the standard weathermap distribution doesn’t include a file called map-poller.php.

Sorry, I don’t know anything about this. I do have access to an observium system, if you can point me in the right direction for the weathermap installation, though. Otherwise, you should talk to observium support people first.